You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

illinoisjim

Senior Member

1

Sunday, May 3rd 2020, 7:27am

Valves leaking until I get more pressure, can't because they are leaking...

System is about 12 years old. I have been having more and more trouble with leaking valves each year, at least that seems to be the issue. Started as trouble with blowout. I am using a small compressor and have trouble getting enough pressure to blow out the zones. Wasn't a problem when the system was new.
Usually run my system off a pump and starting to have trouble with it too. Seems to be an issue with limited pressure/flow. Once I can get the pressure up things work normally. But I suspect the valves aren't closing tightly with lower pressure and with some leaking I can't get the pressure up.
My guess is the diaphragms are getting old and stiff but I could be completely wrong. Hoping people with more knowledge/experience can give me some help. If that's the issue do I just replace them all? I haven't been able to pin point which ones are the issue and suspect there are several.

Maybe I am completely off base and need to be looking at something else but from what I have observed this seems to be the issue.

Rate this thread